La versión de fuse que se instala mediante yum en CentOS es inferior a la necesaria para instalar s3fs, por lo que vamos a compilar el paquete de la versión 2.8.5 necesario para ello.

a) Instalamos las dependencias de s3fs sin fuse:

yum install gcc libstdc++-devel gcc-c++ curl-devel libxml2-devel openssl-devel mailcap

b) Instalamos manualmente fuse

Podemos descargar fuse a través del sitio de sourceforge.net. La última versión en este momento es la 2.8.5.

Descargamos
wget http://downloads.sourceforge.net/project/fuse/fuse-2.X/2.8.5/fuse-2.8.5.tar.gz?r=http%3A%2F%2Fsourceforge.net%2Fprojects%2Ffuse%2Ffiles%2Ffuse-2.X%2F2.8.5%2F&ts=1294249414&use_mirror=softlayer

Descomprimimos el archivo descargado
tar xzf fuse-2.8.5.tar.gz

Compilamos e Instalamos
cd fuse-2.8.5
./configure
make
make install

c) Descargamos e instalamos s3fs

Descargamos
wget http://s3fs.googlecode.com/files/s3fs-1.33.tar.gz

Descomprimimos
tar -xzf s3fs-1.33.tar.gz

IMPORTANTE: Antes de compilar e instalar s3fs, tenemos que indicar donde va a buscar la dependencia de fuse recién instalada. Para eso necesitamos correr lo siguiente:

export PKG_CONFIG_PATH=/usr/local/lib/pkgconfig

Sin esto, s3fs no va a reconocer que ya hemos instalado fuse y nos muestra el siguiente error:

configure: error: Package requirements (fuse >= 2.8.4 libcurl >= 7.0 libxml-2.0 >= 2.6 libcrypto >= 0.9) were not met:
No package ‘fuse’ found

Ahora si, compilamos e instalamos
cd s3fs-1.33
./configure
make
make install

Fuente: linux-en-fedora.com
Anuncios